$re = '/(.*?)(ND_\d_)(Dist_\d_)(.*)/m';
$str = 'Par1_MD_0_5_AL_2_ND_4_Dist_0_Pot_Drop_out.txt
Par1_MD_0_5_AL_2_ND_4_Dist_1_Pot_Drop_out.txt
Par1_MD_0_5_AL_2_ND_6_Dist_2_Pot_Drop_out.txt
Par1_MD_0_5_AL_2_ND_8_Dist_3_Pot_Drop_out.txt
';
$subst = "$1$3$2$4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;