const regex = /<(\w+)\s[^>]*id=\"editable4\"[^>]*>[\s\S]*\1>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(\\w+)\\s[^>]*id=\\"editable4\\"[^>]*>[\\s\\S]*\\1>', 'gm')
const str = `
<body>
<h1 id="editable1" class="editable" contenteditable="false">
h8888899</h1>
<p id="editable2" class="editable">
Lorem ipsum dolor sit amet consectetur,
adipisicing elit. Ad, veniam in tempora voluptatum vel
sequi, nulla, corporis nobis eum aliquid molestiae porro
culpa doloribus. At eveniet quaerat possimus tempora nulla.
</p>
<h2 id="editable3" class="editable">
h2 Lorem ipsum dolor sit amet consectetur
</h2>
<br>
<div id="editable_div1" class="editable">
DIV1 sequi, nulla, corporis nobis eum aliquid molestiae porro
culpa doloribus. At eveni
</div>
<br>
<p id="editable4" class="editable">
Lorem ipsum dolor sit amet consectetur,
adipisicing elit. Ad, veniam in tempora voluptatum vel
sequi, nulla, corporis nobis eum aliquid molestiae porro
culpa doloribus. At eveniet quaerat possimus tempora nulla.
</p>
<br>
<div id="editable_div" class="editable">
DIV sequi, nulla, corporis nobis eum aliquid molestiae porro
culpa doloribus. At eveni
</div>
<br>
<h3 id="editable5" class="editable">
h3 Lorem ipsum dolor sit amet consectetur
</h3>
<p id="editable6" class="editable">
Lorem ipsum dolor sit amet consectetur,
adipisicing elit. Ad, veniam in tempora voluptatum vel
sequi, nulla, corporis nobis eum aliquid molestiae porro
culpa doloribus. At eveniet quaerat possimus tempora nulla.
</p>
<br>
<br>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}