use strict;
my $str = '
<body>
<h1 id="editable1" class="editable" contenteditable="false">
h8888899</h1>
<p id="editable2" class="editable">
Lorem ipsum dolor sit amet consectetur,
adipisicing elit. Ad, veniam in tempora voluptatum vel
sequi, nulla, corporis nobis eum aliquid molestiae porro
culpa doloribus. At eveniet quaerat possimus tempora nulla.
</p>
<h2 id="editable3" class="editable">
h2 Lorem ipsum dolor sit amet consectetur
</h2>
<br>
<div id="editable_div1" class="editable">
DIV1 sequi, nulla, corporis nobis eum aliquid molestiae porro
culpa doloribus. At eveni
</div>
<br>
<p id="editable4" class="editable">
Lorem ipsum dolor sit amet consectetur,
adipisicing elit. Ad, veniam in tempora voluptatum vel
sequi, nulla, corporis nobis eum aliquid molestiae porro
culpa doloribus. At eveniet quaerat possimus tempora nulla.
</p>
<br>
<div id="editable_div" class="editable">
DIV sequi, nulla, corporis nobis eum aliquid molestiae porro
culpa doloribus. At eveni
</div>
<br>
<h3 id="editable5" class="editable">
h3 Lorem ipsum dolor sit amet consectetur
</h3>
<p id="editable6" class="editable">
Lorem ipsum dolor sit amet consectetur,
adipisicing elit. Ad, veniam in tempora voluptatum vel
sequi, nulla, corporis nobis eum aliquid molestiae porro
culpa doloribus. At eveniet quaerat possimus tempora nulla.
</p>
<br>
<br>
';
my $regex = qr/<(\w+)\s[^>]*id=\"editable4\"[^>]*>[\s\S]*\1>/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}