import Foundation
let pattern = #"<(\w+)\s[^>]*id=\"editable4\"[^>]*>[\s\S]*\1>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<body>
<h1 id="editable1" class="editable" contenteditable="false">
h8888899</h1>
<p id="editable2" class="editable">
Lorem ipsum dolor sit amet consectetur,
adipisicing elit. Ad, veniam in tempora voluptatum vel
sequi, nulla, corporis nobis eum aliquid molestiae porro
culpa doloribus. At eveniet quaerat possimus tempora nulla.
</p>
<h2 id="editable3" class="editable">
h2 Lorem ipsum dolor sit amet consectetur
</h2>
<br>
<div id="editable_div1" class="editable">
DIV1 sequi, nulla, corporis nobis eum aliquid molestiae porro
culpa doloribus. At eveni
</div>
<br>
<p id="editable4" class="editable">
Lorem ipsum dolor sit amet consectetur,
adipisicing elit. Ad, veniam in tempora voluptatum vel
sequi, nulla, corporis nobis eum aliquid molestiae porro
culpa doloribus. At eveniet quaerat possimus tempora nulla.
</p>
<br>
<div id="editable_div" class="editable">
DIV sequi, nulla, corporis nobis eum aliquid molestiae porro
culpa doloribus. At eveni
</div>
<br>
<h3 id="editable5" class="editable">
h3 Lorem ipsum dolor sit amet consectetur
</h3>
<p id="editable6" class="editable">
Lorem ipsum dolor sit amet consectetur,
adipisicing elit. Ad, veniam in tempora voluptatum vel
sequi, nulla, corporis nobis eum aliquid molestiae porro
culpa doloribus. At eveniet quaerat possimus tempora nulla.
</p>
<br>
<br>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)