package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?:1,[2-9]|(?:[2-9]|[1-9]\d{1,2}),\d)\d\d,\d{3} K`)
var str = `1,100,000 K
1,200,000 K
1,455,204 K
1,800,000 K
2,000,000 K
15,000,000 K`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}