re = /\b(?:1,[2-9]|(?:[2-9]|[1-9]\d{1,2}),\d)\d\d,\d{3} K/m
str = '1,100,000 K
1,200,000 K
1,455,204 K
1,800,000 K
2,000,000 K
15,000,000 K'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end