const regex = /\b(?:1,[2-9]|(?:[2-9]|[1-9]\d{1,2}),\d)\d\d,\d{3} K/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:1,[2-9]|(?:[2-9]|[1-9]\\d{1,2}),\\d)\\d\\d,\\d{3} K', 'gm')
const str = `1,100,000 K
1,200,000 K
1,455,204 K
1,800,000 K
2,000,000 K
15,000,000 K`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}