#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Pixel [3456]"
Local $sString = "Pixel 7 Pro" & @CRLF & _
"Pixel 7" & @CRLF & _
"Pixel 3" & @CRLF & _
"Pixel 3 XL" & @CRLF & _
"Pixel 6" & @CRLF & _
"Pixel 4" & @CRLF & _
"Pixel 5" & @CRLF & _
"Pixel 3a" & @CRLF & _
"Pixel 6 Pro" & @CRLF & _
"Pixel 6 Pro" & @CRLF & _
"Pixel 3" & @CRLF & _
"Pixel 3 XL" & @CRLF & _
"Pixel 3a" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")