import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Pixel [3456]";
final String string = "Pixel 7 Pro\n"
+ "Pixel 7\n"
+ "Pixel 3\n"
+ "Pixel 3 XL\n"
+ "Pixel 6\n"
+ "Pixel 4\n"
+ "Pixel 5\n"
+ "Pixel 3a\n"
+ "Pixel 6 Pro\n"
+ "Pixel 6 Pro\n"
+ "Pixel 3\n"
+ "Pixel 3 XL\n"
+ "Pixel 3a\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}