using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Pixel [3456]";
string input = @"Pixel 7 Pro
Pixel 7
Pixel 3
Pixel 3 XL
Pixel 6
Pixel 4
Pixel 5
Pixel 3a
Pixel 6 Pro
Pixel 6 Pro
Pixel 3
Pixel 3 XL
Pixel 3a
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}