use strict;
my $str = 'c://abc/def/
c://abc/def
c:\\\\abc\\def\\';
my $regex = qr/[\\\/]$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";