import re
regex = re.compile(r"[\\\/]$", flags=re.MULTILINE)
test_str = ("c://abc/def/\n"
"c://abc/def\n"
"c:\\\\abc\\def\\")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)