const regex = /(.*)((?<=[.!?]\s|^).*?lockbox.*?)(?<=[.!?]|$)(.*)/igs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*)((?<=[.!?]\\s|^).*?lockbox.*?)(?<=[.!?]|$)(.*)', 'igs')
const str = `Prickelnder Zitronengeschmack aus Bad Liebenwerda. Abgefüllt in leichte 1,0 Liter PET-Mehrwegflaschen kommt die Zitronenlimonade im 12er Kasten direkt per Lockbox zu dir nach Hause. Heute bestellt, morgen oder zum Wunschtermin auf dem Küchentisch! Lieferung per Lockbox jeweils von Montag bis Freitag.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}