re = /(.*)((?<=[.!?]\s|^).*?lockbox.*?)(?<=[.!?]|$)(.*)/i
str = 'Prickelnder Zitronengeschmack aus Bad Liebenwerda. Abgefüllt in leichte 1,0 Liter PET-Mehrwegflaschen kommt die Zitronenlimonade im 12er Kasten direkt per Lockbox zu dir nach Hause. Heute bestellt, morgen oder zum Wunschtermin auf dem Küchentisch! Lieferung per Lockbox jeweils von Montag bis Freitag.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end