$re = '/^([a-zA-Z]{2})\/(?:[a-zA-Z]{2}\/)*(?:[a-zA-Z]{2})\/?$/m';
$str = 'de/fr/en/de/en
en/fr/en/de/fr';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);