package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^[ABC]{3}-[DEF]{3}-.+$`)
var str = `ABC-DEF-17-021
bbc-def-1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}