$re = '/^[ABC]{3}-[DEF]{3}-.+$/mi';
$str = 'ABC-DEF-17-021
bbc-def-1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);