const regex = /^[ABC]{3}-[DEF]{3}-.+$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[ABC]{3}-[DEF]{3}-.+$', 'gmi')
const str = `ABC-DEF-17-021
bbc-def-1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}