import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\S)[^\\w\\s]+(?!\\S)";
final String string = "#$# Name Id Salary Desgn\n"
+ "0 Mike B1230 3000 Engg\n"
+ "1 John !@# 3000 !@#&\n"
+ "2 Lucy B1230 3000 %@# \n"
+ "a @#@& @#@& @#@& @#@&\n"
+ "4 snow B1230 3000 Engg\n"
+ "5 Lily #&-@ 3000 Engg $%#$%$#$\n\n"
+ "@#& 123,'.'!@ #-. Mn";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}