import re
regex = re.compile(r"(?<!\S)[^\w\s]+(?!\S)")
test_str = ("#$# Name Id Salary Desgn\n"
"0 Mike B1230 3000 Engg\n"
"1 John !@# 3000 !@#&\n"
"2 Lucy B1230 3000 %@# \n"
"a @#@& @#@& @#@& @#@&\n"
"4 snow B1230 3000 Engg\n"
"5 Lily #&-@ 3000 Engg $%#$%$#$\n\n"
"@#& 123,'.'!@ #-. Mn")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")