$re = '/(?<!\S)[^\w\s]+(?!\S)/';
$str = '#$# Name Id Salary Desgn
0 Mike B1230 3000 Engg
1 John !@# 3000 !@#&
2 Lucy B1230 3000 %@#
a @#@& @#@& @#@& @#@&
4 snow B1230 3000 Engg
5 Lily #&-@ 3000 Engg $%#$%$#$
@#& 123,\'.\'!@ #-. Mn';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);