using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[[.]]{9}+[[.]]{3}+[[.]]{1}+[[.]]{2} ]";
string input = @"000000000+000+0+00
000000001+000+0+00
000000002+000+0+00";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}