// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[[.]]{9}+[[.]]{3}+[[.]]{1}+[[.]]{2} ]").unwrap();
let string = "000000000+000+0+00
000000001+000+0+00
000000002+000+0+00";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}