import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d+x\\d+)$";
final String string = "300x250\n"
+ "160x600\n"
+ "728x90\n"
+ "100x100x200\n"
+ "100x14\n\n\n\n"
+ "abcx1023\n\n\n\n"
+ "10x123\n\n\n\n"
+ "100x2000\n"
+ "100x200x49\n\n"
+ "1x1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}