import re
regex = re.compile(r"^(\d+x\d+)$", flags=re.MULTILINE)
test_str = ("300x250\n"
"160x600\n"
"728x90\n"
"100x100x200\n"
"100x14\n\n\n\n"
"abcx1023\n\n\n\n"
"10x123\n\n\n\n"
"100x2000\n"
"100x200x49\n\n"
"1x1")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")