const regex = /^(\d+x\d+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d+x\\d+)$', 'gm')
const str = `300x250
160x600
728x90
100x100x200
100x14
abcx1023
10x123
100x2000
100x200x49
1x1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}