using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\}\s*(\w+)(?=\s*\{)";
string input = @" solvers
{
p
{
solver PCG;
preconditioner DIC;
tolerance 1e-06;
relTol 0.05;
}
q
{
solver PCG;
relTol 0.03;
}
}";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}