const regex = /\}\s*(\w+)(?=\s*\{)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\}\\s*(\\w+)(?=\\s*\\{)', '')
const str = ` solvers
{
p
{
solver PCG;
preconditioner DIC;
tolerance 1e-06;
relTol 0.05;
}
q
{
solver PCG;
relTol 0.03;
}
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}