import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\}\\s*(\\w+)(?=\\s*\\{)";
final String string = " solvers \n"
+ " { \n"
+ " p\n"
+ " { \n"
+ " solver PCG; \n"
+ " preconditioner DIC; \n"
+ " tolerance 1e-06; \n"
+ " relTol 0.05; \n"
+ " }\n\n"
+ " q\n"
+ " {\n"
+ " solver PCG;\n"
+ " relTol 0.03;\n"
+ " }\n"
+ " }";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}