#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)dark:\w+?[^" ]+"
Local $sString = "<div class="bg-white dark:bg-slate-800 rounded-lg px-6 py-8 ring-1 ring-slate-900/5 shadow-xl">" & @CRLF & _
" <div>" & @CRLF & _
" <span class="inline-flex items-center justify-center p-2 bg-indigo-500 rounded-md shadow-lg">" & @CRLF & _
" <svg class="h-6 w-6 text-white" xmlns="http://www.w3.org/2000/svg" fill="none" viewBox="0 0 24 24" stroke="currentColor" aria-hidden="true"><!-- ... --></svg>" & @CRLF & _
" </span>" & @CRLF & _
" </div>" & @CRLF & _
" <h3 class="text-slate-900 dark:text-white mt-5 text-base font-medium tracking-tight">Writes Upside-Down</h3>" & @CRLF & _
" <p class="text-slate-500 dark:text-slate-400 mt-2 text-sm">" & @CRLF & _
" <p class="text-slate-500 dark:text-slate-400">" & @CRLF & _
" The Zero Gravity Pen can be used to write in any orientation, including upside-down. It even works in outer space." & @CRLF & _
" </p>" & @CRLF & _
"</div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")