# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"dark:\w+?[^\" ]+"
test_str = ("<div class=\"bg-white dark:bg-slate-800 rounded-lg px-6 py-8 ring-1 ring-slate-900/5 shadow-xl\">\n"
" <div>\n"
" <span class=\"inline-flex items-center justify-center p-2 bg-indigo-500 rounded-md shadow-lg\">\n"
" <svg class=\"h-6 w-6 text-white\" xmlns=\"http://www.w3.org/2000/svg\" fill=\"none\" viewBox=\"0 0 24 24\" stroke=\"currentColor\" aria-hidden=\"true\"><!-- ... --></svg>\n"
" </span>\n"
" </div>\n"
" <h3 class=\"text-slate-900 dark:text-white mt-5 text-base font-medium tracking-tight\">Writes Upside-Down</h3>\n"
" <p class=\"text-slate-500 dark:text-slate-400 mt-2 text-sm\">\n"
" <p class=\"text-slate-500 dark:text-slate-400\">\n"
" The Zero Gravity Pen can be used to write in any orientation, including upside-down. It even works in outer space.\n"
" </p>\n"
"</div>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.