const regex = /^Major\s+(?<Major>.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^Major\\s+(?<Major>.*)', 'gm')
const str = `Major SIPCM *SipCmRecvFromTcpSocket: Error in reading data on socketId 247, errno=104
Major NRS ARP lookup for 216.20.237.19 on interface pkt0 with addrContextId 1 failed: SIOGARP error , error 6
Major LVM *NpMediaYmacRespHdlr: error code 0x3 recvd for bcm cmd 4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}