$re = '/^Major\s+(?<Major>.*)/m';
$str = 'Major SIPCM *SipCmRecvFromTcpSocket: Error in reading data on socketId 247, errno=104
Major NRS ARP lookup for 216.20.237.19 on interface pkt0 with addrContextId 1 failed: SIOGARP error , error 6
Major LVM *NpMediaYmacRespHdlr: error code 0x3 recvd for bcm cmd 4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);