use strict;
my $str = 'Major SIPCM *SipCmRecvFromTcpSocket: Error in reading data on socketId 247, errno=104
Major NRS ARP lookup for 216.20.237.19 on interface pkt0 with addrContextId 1 failed: SIOGARP error , error 6
Major LVM *NpMediaYmacRespHdlr: error code 0x3 recvd for bcm cmd 4';
my $regex = qr/^Major\s+(?<Major>.*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}