package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[^aeiou\n]*[aeiou]){2}.*`)
var str = `this is a test
1234
dragon
baseball
football
monkey
abc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}