re = /^(?:[^aeiou\n]*[aeiou]){2}.*/m
str = 'this is a test
1234
dragon
baseball
football
monkey
abc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end