$re = '/^(?:[^aeiou\n]*[aeiou]){2}.*/m';
$str = 'this is a test
1234
dragon
baseball
football
monkey
abc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);