const regex = /(?:(?<=p>)(.+)|(.+)(?=<p)|^.*$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?<=p>)(.+)|(.+)(?=<p)|^.*$)', 'gm')
const str = `<span class="caret"><p class="text" aria-hidden="true">text</p></span>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);