$re = '/(?:(?<=p>)(.+)|(.+)(?=<p)|^.*$)/m';
$str = '<span class="caret"><p class="text" aria-hidden="true">text</p></span>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;