use strict;
my $str = '<span class="caret"><p class="text" aria-hidden="true">text</p></span>';
my $regex = qr/(?:(?<=p>)(.+)|(.+)(?=<p)|^.*$)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";