using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?<=^by ).*(?= \|))|((?<=\| by ).*(?= \|))";
string input = @"Part of: Excel For Beginners (3 Books) | by Henry E. Mejia | Apr 4, 2021";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}