re = /((?<=^by ).*(?= \|))|((?<=\| by ).*(?= \|))/m
str = 'Part of: Excel For Beginners (3 Books) | by Henry E. Mejia | Apr 4, 2021'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end