package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([+-]) (~?\w+)|\(.*\) ?(?:: (.+))?`)
var str = ` + Update () : void
+ KeyPress (key : int) : bool
+ KeyRelease (key : int) : bool
+ IsKeyDown (key : int) : bool
+ MousePress (button : int) : bool
+ MouseRelease (button : int) : bool
+ IsMouseDown (button : int) : bool
+ GetMouseX () : int
+ GetMouseY () : int
+ QuitRequested () : bool
+ GetInstance () : InputManager&
- InputManager ()
- ~InputManager ()
- mouseState : bool[6]
- mouseUpdate : int[6]
- keyState : ler abaixo
- keyUpdate : ler abaixo
- quitRequested : bool
- updateCounter : int
- mouseX : int
- mouseY : int
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}