import re
regex = re.compile(r"([+-]) (~?\w+)|\(.*\) ?(?:: (.+))?", flags=re.MULTILINE)
test_str = (" + Update () : void\n\n"
" + KeyPress (key : int) : bool\n"
" + KeyRelease (key : int) : bool\n"
" + IsKeyDown (key : int) : bool\n\n"
" + MousePress (button : int) : bool\n"
" + MouseRelease (button : int) : bool\n"
" + IsMouseDown (button : int) : bool\n\n"
" + GetMouseX () : int\n"
" + GetMouseY () : int\n\n"
" + QuitRequested () : bool\n\n"
" + GetInstance () : InputManager&\n\n"
" - InputManager ()\n"
" - ~InputManager ()\n\n\n"
" - mouseState : bool[6]\n"
" - mouseUpdate : int[6]\n\n"
" - keyState : ler abaixo\n"
" - keyUpdate : ler abaixo\n\n"
" - quitRequested : bool\n\n"
" - updateCounter : int\n\n"
" - mouseX : int\n"
" - mouseY : int\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")