$re = '/([+-]) (~?\w+)|\(.*\) ?(?:: (.+))?/m';
$str = ' + Update () : void
+ KeyPress (key : int) : bool
+ KeyRelease (key : int) : bool
+ IsKeyDown (key : int) : bool
+ MousePress (button : int) : bool
+ MouseRelease (button : int) : bool
+ IsMouseDown (button : int) : bool
+ GetMouseX () : int
+ GetMouseY () : int
+ QuitRequested () : bool
+ GetInstance () : InputManager&
- InputManager ()
- ~InputManager ()
- mouseState : bool[6]
- mouseUpdate : int[6]
- keyState : ler abaixo
- keyUpdate : ler abaixo
- quitRequested : bool
- updateCounter : int
- mouseX : int
- mouseY : int
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);