#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[.,](?!(?<=\d.)\d)"
Local $sString = "14,000$" & @CRLF & _
"53.31s" & @CRLF & _
"" & @CRLF & _
"thank you.see you soon!" & @CRLF & _
"hey,what's up?" & @CRLF & _
"" & @CRLF & _
"123,abc" & @CRLF & _
"abc,123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")