import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[.,](?!(?<=\\d.)\\d)";
final String string = "14,000$\n"
+ "53.31s\n\n"
+ "thank you.see you soon!\n"
+ "hey,what's up?\n\n"
+ "123,abc\n"
+ "abc,123";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}