$re = '/[.,](?!(?<=\d.)\d)/m';
$str = '14,000$
53.31s
thank you.see you soon!
hey,what\'s up?
123,abc
abc,123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);