import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Z]{2,}-\\d+(?:\\([^)]+\\))?)\\s([a-zA-Z]+\\s?[a-zA-Z]+)\\s\\d*-\\d*\\s([a-zA-Z]+\\s?[a-zA-Z]+\\s?[a-zA-Z]+)";
final String string = "Design No. TAHN-7075 Natural Gray 0997-101 White 0911-101\n\n"
+ "Design No. TAHN-7082(CS-02) Natural Gray 0997-101 Natural Gray 0997-101";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}