const regex = /([A-Z]{2,}-\d+(?:\([^)]+\))?)\s([a-zA-Z]+\s?[a-zA-Z]+)\s\d*-\d*\s([a-zA-Z]+\s?[a-zA-Z]+\s?[a-zA-Z]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([A-Z]{2,}-\\d+(?:\\([^)]+\\))?)\\s([a-zA-Z]+\\s?[a-zA-Z]+)\\s\\d*-\\d*\\s([a-zA-Z]+\\s?[a-zA-Z]+\\s?[a-zA-Z]+)', 'gm')
const str = `Design No. TAHN-7075 Natural Gray 0997-101 White 0911-101
Design No. TAHN-7082(CS-02) Natural Gray 0997-101 Natural Gray 0997-101`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}